SMS delivery issues
Incident Report for Yodel
Resolved
This incident has been resolved.
Posted Jul 16, 2018 - 21:07 UTC
Identified
It seems that our carrier has problems with delivering SMS. We will keep you updated.
Posted Jul 16, 2018 - 19:49 UTC
Investigating
We are currently investigating this issue.
Posted Jul 16, 2018 - 19:41 UTC
This incident affected: Carrier (SMS).