Elevated failures on calls to France
Incident Report for Yodel
Resolved
This incident has been resolved.
Posted Jun 11, 2018 - 16:15 UTC
Investigating
We are currently experiencing an elevated number of failed calls to French numbers when dialing from France numbers. We are engaging with our carrier partners to resolve the issue.
Posted Jun 11, 2018 - 14:42 UTC
This incident affected: Carrier (Voice (PSTN)).