We're investigating a problem resulting in an increased rate of call failures.
Incident Report for Yodel
Resolved
This incident has been resolved.
Posted Jun 21, 2018 - 22:17 UTC
Investigating
We are currently investigating this issue.
Posted Jun 21, 2018 - 21:54 UTC
This incident affected: Carrier (Voice (PSTN), Voice (Web), Voice (Mobile), Router, Conference, Transcriptions).